Discussion:
Gluster install using Ganesha for NFS
(too old to reply)
Anthony Valentine
2017-07-06 16:42:47 UTC
Permalink
Raw Message
Hello!

I am attempting to setup a Gluster install using Ganesha for NFS using the guide found here http://blog.gluster.org/2015/10/linux-scale-out-nfsv4-using-nfs-ganesha-and-glusterfs-one-step-at-a-time/

The Gluster portion is working fine, however when I try to setup Ganesha I have a problem. The guide says to run 'gluster nfs-ganesha enable' however when I do, I get the following error:

[***@glustertest1 ~]# gluster nfs-ganesha enable
unrecognized word: nfs-ganesha (position 0)

Has this command changed? If so, what is the new command? If not, why would I be getting this error?

Is there a more recent guide that I should be following?


Thank you in advance!

Anthony Valentine
Kaleb S. KEITHLEY
2017-07-06 17:31:34 UTC
Permalink
Raw Message
After 3.10 you'd need to use storhaug.... Which.... doesn't work (yet).

You need to use 3.10 for now.

On 07/06/2017 12:53 PM, Anthony Valentine wrote:
> I'm running this on CentOS 7.3
>
> [***@glustertest1 ~]# cat /etc/redhat-release
> CentOS Linux release 7.3.1611 (Core)
>
>
> Here are the software versions I have installed.
>
> [***@glustertest1 ~]# rpm -qa | egrep -i "nfs|gluster|ganesha"
> glusterfs-api-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-server-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-libs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-gluster-2.4.5-1.el7.x86_64
> nfs-ganesha-utils-2.4.5-1.el7.x86_64
> centos-release-gluster310-1.0-1.el7.centos.noarch
> nfs-utils-1.3.0-0.33.el7_3.x86_64
> glusterfs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-2.4.5-1.el7.x86_64
> libnfsidmap-0.25-15.el7.x86_64
> glusterfs-client-xlators-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-cli-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-fuse-3.11.0-0.1.rc0.el7.x86_64
>
> -----Original Message-----
> From: Kaleb S. KEITHLEY [mailto:***@redhat.com]
> Sent: Thursday, July 6, 2017 10:49 AM
> To: Anthony Valentine <***@bldr.com>
> Subject: Re: [Gluster-users] Gluster install using Ganesha for NFS
>
> On 07/06/2017 12:42 PM, Anthony Valentine wrote:
>> Hello!
>>
>> I am attempting to setup a Gluster install using Ganesha for NFS using
>> the guide found here
>> http://blog.gluster.org/2015/10/linux-scale-out-nfsv4-using-nfs-ganesh
>> a-and-glusterfs-one-step-at-a-time/
>>
>>
>> The Gluster portion is working fine, however when I try to setup
>> Ganesha I have a problem. The guide says to run 'gluster nfs-ganesha enable'
>> however when I do, I get the following error:
>>
>> [***@glustertest1 ~]# gluster nfs-ganesha enable
>>
>> unrecognized word: nfs-ganesha (position 0)
>>
>> Has this command changed? If so, what is the new command? If not,
>> why would I be getting this error?
>>
>> Is there a more recent guide that I should be following?
>
> It could use some updating but it's mostly accurate.
>
> What version of gluster? That command should work.
>
> --
>
> Kaleb
>
>
>
>
Anthony Valentine
2017-07-06 21:22:09 UTC
Permalink
Raw Message
That was the problem, thank you!

-----Original Message-----
From: Kaleb S. KEITHLEY [mailto:***@redhat.com]
Sent: Thursday, July 6, 2017 11:32 AM
To: Anthony Valentine <***@bldr.com>; Gluster Users <gluster-***@gluster.org>
Subject: Re: [Gluster-users] Gluster install using Ganesha for NFS


After 3.10 you'd need to use storhaug.... Which.... doesn't work (yet).

You need to use 3.10 for now.

On 07/06/2017 12:53 PM, Anthony Valentine wrote:
> I'm running this on CentOS 7.3
>
> [***@glustertest1 ~]# cat /etc/redhat-release CentOS Linux release
> 7.3.1611 (Core)
>
>
> Here are the software versions I have installed.
>
> [***@glustertest1 ~]# rpm -qa | egrep -i "nfs|gluster|ganesha"
> glusterfs-api-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-server-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-libs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-gluster-2.4.5-1.el7.x86_64
> nfs-ganesha-utils-2.4.5-1.el7.x86_64
> centos-release-gluster310-1.0-1.el7.centos.noarch
> nfs-utils-1.3.0-0.33.el7_3.x86_64
> glusterfs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-2.4.5-1.el7.x86_64
> libnfsidmap-0.25-15.el7.x86_64
> glusterfs-client-xlators-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-cli-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-fuse-3.11.0-0.1.rc0.el7.x86_64
>
> -----Original Message-----
> From: Kaleb S. KEITHLEY [mailto:***@redhat.com]
> Sent: Thursday, July 6, 2017 10:49 AM
> To: Anthony Valentine <***@bldr.com>
> Subject: Re: [Gluster-users] Gluster install using Ganesha for NFS
>
> On 07/06/2017 12:42 PM, Anthony Valentine wrote:
>> Hello!
>>
>> I am attempting to setup a Gluster install using Ganesha for NFS
>> using the guide found here
>> http://blog.gluster.org/2015/10/linux-scale-out-nfsv4-using-nfs-ganes
>> h
>> a-and-glusterfs-one-step-at-a-time/
>>
>>
>> The Gluster portion is working fine, however when I try to setup
>> Ganesha I have a problem. The guide says to run 'gluster nfs-ganesha enable'
>> however when I do, I get the following error:
>>
>> [***@glustertest1 ~]# gluster nfs-ganesha enable
>>
>> unrecognized word: nfs-ganesha (position 0)
>>
>> Has this command changed? If so, what is the new command? If not,
>> why would I be getting this error?
>>
>> Is there a more recent guide that I should be following?
>
> It could use some updating but it's mostly accurate.
>
> What version of gluster? That command should work.
>
> --
>
> Kaleb
>
>
>
>
Mahdi Adnan
2017-07-07 10:09:43 UTC
Permalink
Raw Message
Hi,


Why change to storhaug ? and whats going to happen to the current setup if i want to update Gluster to 3.11 or beyond ?


--

Respectfully
Mahdi A. Mahdi

________________________________
From: gluster-users-***@gluster.org <gluster-users-***@gluster.org> on behalf of Kaleb S. KEITHLEY <***@redhat.com>
Sent: Thursday, July 6, 2017 8:31:34 PM
To: Anthony Valentine; Gluster Users
Subject: Re: [Gluster-users] Gluster install using Ganesha for NFS


After 3.10 you'd need to use storhaug.... Which.... doesn't work (yet).

You need to use 3.10 for now.

On 07/06/2017 12:53 PM, Anthony Valentine wrote:
> I'm running this on CentOS 7.3
>
> [***@glustertest1 ~]# cat /etc/redhat-release
> CentOS Linux release 7.3.1611 (Core)
>
>
> Here are the software versions I have installed.
>
> [***@glustertest1 ~]# rpm -qa | egrep -i "nfs|gluster|ganesha"
> glusterfs-api-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-server-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-libs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-gluster-2.4.5-1.el7.x86_64
> nfs-ganesha-utils-2.4.5-1.el7.x86_64
> centos-release-gluster310-1.0-1.el7.centos.noarch
> nfs-utils-1.3.0-0.33.el7_3.x86_64
> glusterfs-3.11.0-0.1.rc0.el7.x86_64
> nfs-ganesha-2.4.5-1.el7.x86_64
> libnfsidmap-0.25-15.el7.x86_64
> glusterfs-client-xlators-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-cli-3.11.0-0.1.rc0.el7.x86_64
> glusterfs-fuse-3.11.0-0.1.rc0.el7.x86_64
>
> -----Original Message-----
> From: Kaleb S. KEITHLEY [mailto:***@redhat.com]
> Sent: Thursday, July 6, 2017 10:49 AM
> To: Anthony Valentine <***@bldr.com>
> Subject: Re: [Gluster-users] Gluster install using Ganesha for NFS
>
> On 07/06/2017 12:42 PM, Anthony Valentine wrote:
>> Hello!
>>
>> I am attempting to setup a Gluster install using Ganesha for NFS using
>> the guide found here
>> http://blog.gluster.org/2015/10/linux-scale-out-nfsv4-using-nfs-ganesh
>> a-and-glusterfs-one-step-at-a-time/
>>
>>
>> The Gluster portion is working fine, however when I try to setup
>> Ganesha I have a problem. The guide says to run 'gluster nfs-ganesha enable'
>> however when I do, I get the following error:
>>
>> [***@glustertest1 ~]# gluster nfs-ganesha enable
>>
>> unrecognized word: nfs-ganesha (position 0)
>>
>> Has this command changed? If so, what is the new command? If not,
>> why would I be getting this error?
>>
>> Is there a more recent guide that I should be following?
>
> It could use some updating but it's mostly accurate.
>
> What version of gluster? That command should work.
>
> --
>
> Kaleb
>
>
>
>
Loading...